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Make Book Jacket Overview
Enter your measurements for flaps, cover, and spine, etc. and Make Book Jacket 

will create a new InDesign document for you, properly measured and complete 

with guides, bleed, crop/fold marks and more. The tedious work that used to take 

minutes of “careful” measuring now takes seconds, with perfect accuracy.

What’s even more amazing, is that you can edit the jacket’s sizes after the file has 

been created. Now you can change the spine size and more!

There are easy to use preferences that let you control the final book jacket, but 

even if you don’t customize them, the default settings will produce a great jacket. 

Requires Adobe InDesign for Mac or PC
Make Book Jacket works inside of InDesign CS4 or later  

(tested through CS6 and Creative Cloud CC 2019).

OVERVIEW, SYSTEM REQUIREMENTS & SCREENSHOTS

Main Window: Create a New Book Jacket
Inches version shown. Millimeters & Picas versions are also included.

Preferences

Modify An Existing Jacket

https://www.danrodney.com
https://www.danrodney.com
mailto:dan@danrodney.com


empowering people through technology

Make Book Jacket 6.3 for Adobe InDesign COPYRIGHT © 2005–2018 DANRODNEY.COM� dan@danrodney.com  PAGE 3

EXAMPLES & TERMINOLOGY

A Few Examples of What You Can Make
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(Turns around the thickness of the cover.)
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1.	 To install Make Book Jacket, open InDesign’s Scripts panel by going into the 

Window menu and choosing Utilities > Scripts.  

(In InDesign CS4 choose Window > Automation > Scripts.)

2.	 In the Scripts panel you’ll see Application and User folders. Scripts can be 

installed into either, but only admins can install into the Application folder. 

If you’re not an admin (or aren’t sure), choose the User folder. With one of the 

folders selected, at the top right of the panel go into the menu and choose 

Reveal in Finder (Mac) or Reveal in Explorer (PC).

3.	 You should now be in the Scripts folder. Drag the MakeBookJacket folder into 

the Scripts folder (so it appears as shown below).  

Do NOT put it into the Scripts Panel folder as prior versions did! 

4.	 Quit InDesign.

5.	 Relaunch InDesign and a new Jacket menu should appear to the right of the 

View menu. All the features are found in this Jacket menu. Enjoy!

Scripts Folder Location
Curious where the Scripts folders are located?

Mac
•	 Application Folder: Hard Drive > Applications > Adobe InDesign 

[version number] > Scripts

•	 User Folder: Hard Drive > Users > [username] > Library > Preferences > 

Adobe InDesign > Version X.X > Scripts

Windows 10, 8, 7, & Vista
•	 Application Folder: C:Drive > Program Files > Adobe > Adobe InDesign 

[version number] > Scripts

•	 User Folder: C:Drive > Users > [username] > AppData > Roaming > Adobe > 

InDesign > Version X.X > [en_US or other language] > Scripts

Windows XP
•	 Application Folder: C:Drive > Program Files > Adobe > Adobe InDesign 

[version number] > Scripts

•	 User Folder: C:Drive > Documents and Settings > [username] > Application Data > 

Adobe > InDesign > Version X.X > [en_US or other language] > Scripts

HOW TO INSTALL
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USING MAKE BOOK JACKET

Make a New Book Jacket

Choose Jacket > New Book Jacket Enter Sizes/Options Click OK

 

Choose your preferred 

measurements: Inches, 

Millimeters, or Picas.

Enter sizes for  

cover, spine, flaps, etc. 

Change other options if needed.

Refer to the following pages  

for more in depth explanations of  

terminology and features.

Modify an Existing Book Jacket

Open a Document Choose “Modify Current Book jacket” Update Sizes Click OK

Open an InDesign 

file created with 

Make Book Jacket 3.0 

or later. 

You cannot adjust files 

that were not created with 

Make Book Jacket.

Change any size, such 

as spine thickness, etc.
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DESCRIPTION OF FEATURES

Flap Turnaround
The area where the cover folds around the thickness of the cover material and 

becomes the flap is called the Flap Turnaround. If Affects Document Size is 

checked, the turnaround width will be added to the document size (between the 

flap and cover). If Affects Document Size is unchecked, the document size will not 

be increased. Instead, guides will be added around the flap/cover fold line. Half of 

the turnaround width would be on the flap, and the other half on the cover.

Guides
Because guides can be moved or deleted accidently while working, guides and fold/

crop marks are put onto a separate layer which is locked. The other reason they 

are put onto a layer is to keep the marks on top of everything, so they never get 

covered up by the jacket’s artwork. If you don’t want to put them on a separate 

layer, in the Preferences dialog uncheck Make Layer to the right of the Marks & 

Guides Layer name. You can also turn off the auto locking of that layer if desired.

To edit the guides and/or marks of an existing jacket file, choose Jacket > Modify 

Current Book Jacket. If you want to manually change the guides, unlock the Marks 

& Guides layer in the Layers panel (Window > Layers), but the Modify command 

is the recommended way to change them.

Margin Guides
To set custom margins, in the New Book Jacket dialog, choose Custom Margins. 

Click OK and you will be presented with a second dialog. Enter your custom 

margins and click OK again. The jacket will be created.

Slug Guides
By default the slug guides automatically fit to include the fold marks. This 

makes printing the jacket with fold marks easy. Go into File > Print and in the 

Marks and Bleed section (on the left) check on Include Slug Area. The entire 

jacket, bleed and fold marks will be printed.

To set a custom slug area, in the New Book Jacket dialog, choose Custom Slug. 

Click OK and you will be presented with a second dialog. Enter your custom slug 

amounts and click OK again. The jacket will be created.

Fold Marks
Fold Marks are automatically added for the flaps and spine. They are a dashed rule 

but can be changed to dotted in the New Book Jacket dialog where length and 

stroke weight can also be changed. By default the slug guides auto-fit to include the 

fold marks. Therefore when you go to File > Print, in the Marks and Bleed section 

you can check on Include Slug Area to include the fold marks in the print out.

Crop Marks
Crop Marks use the same weight, length and offset settings as fold marks except 

they are a solid line instead of dotted. If you prefer to use InDesign’s built in crop 

marks instead, just uncheck Add Crops Marks.

Fill with Empty Frames
This option is turned off by default, but each section (spine, front cover, etc.) can be 

filled with an empty frame. These frames can contain color, pictures, text, etc. To 

enable this feature go into the Preferences and check on Fill Each Panel with an 

Empty Frame.
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FAQS & TIPS

Q.	 What is a Flap Turnaround?

A.	 This is where the cover folds, turns around the thickness of the cover material, 

and  becomes the flap. By default, the turnaround size is added to the overall 

dimensions of the jacket. Unchecking Turnaround Affects Document Size 

makes it act more like a safety zone around the flap fold. In this case the 

turnaround does not affect document size. Half of the turnaround area is on 

the flap, the other half is on the cover.

Q.	 Must I have a Flap Turnaround?

A.	 No, just make it 0 (zero) to get one guide/set of fold marks between the flap 

and cover instead of the two that would be there with a turnaround.

Q.	 What if I don’t want flaps?

A.	 Just enter 0 (zero) for both front and back flaps. No guides or fold marks will 

be created for flaps.

Q.	 Must I have a spine thickness?

A.	 No, some jackets have no spine because they just fold where the covers meet. 

Just enter 0 (zero) for the spine.

Q.	 What are Slug Guides? Why and how are you using them?

A.	 They are another set of guides similar to bleed guides. The slug area is often 

filled with info such as job information, printing info, editorial approval, etc. I am 

using the slug guides just as an extra set of guides, auto-fitting them to an area 

that includes the fold marks. This let’s you quickly choose whether or not you 

want them included in a print out or PDF. See the tip on the right for more info 

on how.

Q.	 Why can’t I edit the marks and guides?

A.	 By default they are placed on a locked layer. You must unlock the layer before 

you can edit the contents: Go into the Layers panel (Window > Layers). 

Then click the lock next to the marks & guides layer. If you don’t want this 

layer locked, choose Jacket > Preferences and uncheck Lock Marks & 

Guides Layer.

Q.	 Can I change the default settings in the main window?

A.	 Yes. Choose Jacket > New Book Jacket. Enter the options you want and at the 

bottom of the dialog check on Make These Settings the Default and click OK. 

A jacket will be created, but your default settings have also been saved. If you 

don’t want the book jacket, just close the document without saving changes.

Tip: Viewing
Switch into Preview mode (Window > Screen Mode > Preview). Then open the 

Layers panel and show the appropriate Preview layer to view a section of your 

jacket in isolation. For instance you can look at just the spine, or just the front cover. 

This is how your audience will see the jacket on a book shelf! When done with one 

preview layer, hide it and show another Preview layer.

TIP: Speed It Up With a Keystroke
You can assign a keyboard shortcut to the various features. Then you can hit the 

keystroke instead of using the Jacket menu. 

   �– Go into the Edit menu and choose Keyboard Shortcuts. 

– From the Product Area menu choose Scripts. 

– In the list select a feature such as New Book Jacket - [measurement]. 

– Towards the bottom click in the empty field under New Shortcut. 

– Press the desired keys, such as Option–J (Mac) or Alt–J (PC). 

– Click Assign, then click OK.

TIP: Printing & Making a PDF
To print the jacket (or make a PDF) with bleed and fold marks: In the Print (or PDF) 

dialog’s Marks and Bleed section check on Include Slug Area. Please Note: This 

assumes you left Slug: Auto-Fit... checked in the New Book Jacket dialog when 

you originally created the jacket.

https://www.danrodney.com
https://www.danrodney.com
mailto:dan@danrodney.com


empowering people through technology

Make Book Jacket 6.3 for Adobe InDesign COPYRIGHT © 2005–2018 DANRODNEY.COM� dan@danrodney.com  PAGE 8

Restoring Original Preferences & Default Settings
Feel free to experiment with the default settings and preferences, knowing that 

they can be reset to “factory defaults.” Preference files are stored in:

MakeBookJacket > User Preferences and Presets > Default Settings

To open this folder go into the Jacket menu and choose Rename/Delete Presets. 

Click the Show in Finder (Mac) or Show in Explorer (PC) button.

In the Default Settings folder you will find .txt files for each of the 3 types of 

measurements (inches, millimeters and picas). There may also be two other 

preference files. Delete any of these text files and Make Book Jacket will recreate 

clean files as needed. 

Explanation of Preference Files
MakeBookJacketDefaults-[measurement].txt

These three files store the default settings you see in the New Book Jacket dialogs. 

These include default sizes, bleed and mark settings, etc. These settings files get 

updated whenever a user checks on Update Default Settings in the New Book 

Jacket dialog.

Preferences.txt

When you choose Jacket > Preferences, the changes are saved into this file. This 

includes settings such as layer setup, InDesign Preferences, etc.

MakeUsingPresetDefaults.txt

This file isn’t too important. It remembers whether the Make Using Preset dialog 

has the Show the Main Settings Dialog option checked on or not. This “sticky” 

setting is saved here.

CropCoverDefaults.txt

This file isn’t too important. It remembers which option is selected for Crop to 

Front/Back Cover. This “sticky” setting is saved here.

For System Admins and Advanced users
Make Book Jacket is designed for use by individual users as well as multiple users 

in a company. When the default settings have been deleted, the “factory settings” 

will be restored. Some users—especially companies with multiple users—may 

want to customize those “factory defaults.” First you must understand a few things. 

The “factory defaults” are stored in: MakeBookJacket > Make Book Jacket Core > 

Factory Default Settings

Here’s how preference restoration works: First you delete a preference file in the 

Default Settings folder. Then when you run Make Book Jacket, you will be alerted 

that the default settings have been restored. This means Make Book Jacket has 

copied the appropriate file from the Factory Default Settings folder back into the 

Default Settings folder, thus restoring the “factory defaults.”

If you set your desired default settings and preferences, those settings are 

saved into the Default Settings folder. To customize the “factory defaults” you 

can copy your files from the Default Settings folder into the Factory Default 

Settings folder. Later if a user deletes the files in Default Settings, your custom 

“factory defaults” will be restored.

DEALING WITH PREFERENCES
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Purchasing
Visit https://www.danrodney.com or email dan@danrodney.com

Single-User License
Allows an individual to install and use Make Book Jacket on as many machines as 

he/she works on. It is not to be used by multiple persons. Only the person who 

purchased the license has the right to use it. Multiple installed copies cannot be 

used concurrently. Since there is only one licensee, he/she can only be using one 

copy at a time. This license is nontransferable. 

Multi-User License
Allows a company, organization, household, etc. to install and use Make Book 

Jacket on multiple machines. The number of copies that can be installed and 

used concurrently depends on the number of licenses purchased. This license 

is nontransferable.

Terms of Use (Boring Legal Stuff)
Use of Make Book Jacket is subject to the following terms: 

Make Book Jacket is the sole property of Dan Rodney (Copyright © 2005–2018). 

Make Book Jacket is NOT to be distributed freely. 

No part of the script files can be used and/or redistributed as your own.  

In other words: “Please don’t steal my hard work!” 

While I have tested it to the best of my ability and know it to work as I intended, like 

any software there may be bugs that I have yet to find. It is provided “as is” with no 

guarantee of specific functionality. I recommend that you save frequently and keep 

backups of your documents. I am not responsible for any damages or liabilities 

incurred by the use of this product. 

In other words: I’ve worked hard to make sure things should work fine, but in case I 

made a boo-boo please don’t sue me.

LICENSING & LEGAL

https://www.danrodney.com
https://www.danrodney.com
mailto:dan@danrodney.com
https://www.danrodney.com
mailto:dan@danrodney.com

	Overview, System Requirements & Screenshots
	Examples & Terminology
	How to Install
	Using Make Book Jacket
	Description of Features
	FAQs & Tips
	Dealing with Preferences
	Licensing & Legal

