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Description, System Requirements & Screenshots

description of the scripts
Given a set of measurements for flaps, cover, and spine, 
Make Book Jacket will create a new document, properly 
measured and complete with guides, bleed, crop/fold marks and 
more. The tedious work that used to take several minutes of 
“careful” measuring now takes seconds, with perfect accuracy. 

What’s even more amazing, is that you can edit the jacket’s sizes 
after the file has been created. Now you can change the spine 
size and more!

There are numerous preferences to let you control the final 
book jacket, but even if you don’t customize them, the default 
settings will produce a great jacket. 

Make Book Jacket works the same on both Mac and PC.

inches version shown (Millimeters and 
Picas versions are also included)

InDesign CS5.5, CS5, CS4, or CS3

Mac or PC 1024 x 768 screen

 768

1024

Minimum System Requirements

Each purchase includes MBJ 2.0 for InDesign CS2 and MBJ 1.1 for InDesign CS. 
They lack some advanced features of MBJ 4.0, but still work well.
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Examples & Terminology

Here are a few examples of jackets You can make
It also explains some of the terminology.
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flap Turnaround
(Turns around the thickness of the cover.)

Outer & Inner Spine Safety Guides

Bleed

back
Cover
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Installing into CS5.5, CS5, CS4 or CS3
1.	 Open the Scripts Panel as follows: 

InDesign CS5 or Later: Go into the Window > Utilities > Scripts. 
InDesign CS4 or CS3: Go into the Window > Automation > Scripts.

2.	 In the Scripts Panel you’ll see Application and User folders. Scripts can 
be installed into either, but only admins can install into the Application 
folder. If you’re not an admin, choose the User folder. With one of the 
folders selected, at the top right of the panel go into the menu and 
choose Reveal in Finder (Mac) or Reveal in Explorer (PC).

3.	 You should now see a Scripts Panel folder. Drag the script files/folder 
into there and it’s installed!

4.	 Switch back to InDesign and the script will be listed under the folder 
you put it in. To start the script just double-click it and enjoy!

Specific folder locations
Want to know where the Scripts Panel folders are located?

Mac
Hard Drive > Applications > Adobe InDesign CS5.5 (CS5, CS4, etc.) >  
Scripts > Scripts Panel 
or  
Hard Drive > Users > [username] > Library > Preferences > 
Adobe InDesign > Version 7.5 (7.0, 6.0, etc.) > Scripts > Scripts Panel

Windows 7 & Vista
C:Drive > Program Files > Adobe > Adobe InDesign CS5.5 (CS5, CS4, etc.) > 
Scripts > Scripts Panel 
or 
C:Drive > Users > [username] > AppData > Roaming > Adobe > 
InDesign > Version 7.5 (7.0, 6.0, etc.)> [en_US or other language] > 
Scripts > Scripts Panel

Windows XP
C:Drive > Program Files > Adobe > Adobe InDesign CS5.5 (CS5, CS4, etc.) > 
Scripts > Scripts Panel  
or 
C:Drive > Documents and Settings > [username] > 
Application Data > Adobe > InDesign > Version 7.5 (7.0, 6.0, etc.) > 
[en_US or other language] > Scripts > Scripts Panel

How to Install
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Using the Script

Making a new book jacket

Open the scripts panel Double-click the script enter sizes/options Click OK

CS5: Choose Window > Utilities > Scripts. 
CS4–CS3: Window > Automation > Scripts. Enter sizes for  

cover, spine, flaps, etc. 
Change other options 

if needed.

Refer to the following pages  
for more in depth 

explanations of  
terminology and features.

modify an existing book jacket

Open a Document Double-click the script enter new sizes Click OK

Open an InDesign file that was created 
with Make Book Jacket 3.0 or later. 

You cannot adjust jacket files created 
with MBJ 2.0 or earlier, or manually 

created jackets.

Change any size, such as  
spine thickness, etc..
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Description of Features

Flap Turnaround (used to be called Flap Fold Safety Zone):

The area where the cover folds around the thickness of the cover material and 
becomes the flap is called the Flap Turnaround. If Affects Document Size is 
checked, the turnaround width will be added to the document size (between 
the flap and cover). If Affects Document Size is unchecked, the document 
size will not be increased. Instead, guides will be added around the flap/cover 
fold line. Half of the turnaround width would be on the flap, and the other 
half on the cover.

Guides:
Because guides can be moved or deleted accidently while working, guides 
and fold/crop marks are put onto a separate layer which is locked. The other 
reason they are put onto a layer is to keep the marks on top of everything, 
so they never get covered up by the jacket’s artwork. If you don’t want to put 
them on a separate layer, in the Preferences dialog uncheck Make Layer to 
the right of the Marks & Guides Layer name. You can also turn off the auto 
locking of that layer if desired.

If you’ve already created a jacket and wish to edit the guides and/or marks 
created by the script, use the Modify Current Book Jacket script. To 
manually change them simply unlock the marks & guides layer in the Layers 
panel (Window menu > Layers).

Slug guides:
By default the slug guides automatically fit to include the fold marks. This 
makes printing the jacket with fold marks easy. Go into File > Print and 
in the Marks and Bleed section (on the left) check on Include Slug Area. 
The entire jacket, bleed and fold marks will be printed.

To set a custom slug area, in the main script window, choose Custom Slug. 
Click OK and you will be presented with a second dialog. Enter your custom 
slug amounts and click OK again. The jacket will be created.

Margin guides:
To set custom margins, in the main script dialog, choose Custom Margins. 
Click OK and you will be presented with a second dialog. Enter your custom 
margins and click OK again. The jacket will be created.

Fold Marks:
Fold Marks are automatically added for the flaps and spine. They are a dashed 
rule but can be changed to dotted in the Make Book Jacket dialog where 
length and stroke weight can also be changed. By default the script auto-fits 
the slug guides to include the fold marks. Therefore when you go to File > 
Print, in the Marks and Bleed section you can check on Include Slug Area 
to include the fold marks in the print out.

Crop Marks:
Crop Marks use the same weight, length and offset settings as fold marks 
except they are a solid line instead of dotted. If you prefer to use InDesign’s 
built in crop marks instead, just uncheck Add Crops Marks.

Fill with Empty Frames:
This option is not turned off by default, but each section (spine, front cover, 
etc.) can be filled with an empty frame. These frames can contain color, 
pictures, text, etc. To enable this feature go into the Preferences and check 
on Fill Each Panel with an Empty Frame.
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Q.	 What is a Flap Turnaround?
A.	 This is where the cover folds, turns around the thickness of the cover 

material, and  becomes the flap. By default, the turnaround size is added 
to the overall dimensions of the jacket. Unchecking Turnaround Affects 
Document Size makes it act more like a safety zone around the flap 
fold. In this case the turnaround does not affect document size. Half of 
the turnaround area is on the flap, the other half is on the cover.

Q.	 Must I have a Flap Turnaround?
A.	 No, just make it 0 (zero) to get one guide/set of fold marks between the 

flap and cover instead of the two that would be there with a turnaround.

Q.	 What if I don’t want flaps?
A.	 Just enter 0 (zero) for both front and back flaps. No guides or fold 

marks will be created for flaps.

Q.	 Must I have a spine thickness?
A.	 No, some jackets have no spine because they just fold where the covers 

meet. Just enter 0 (zero) for the spine.

Q.	 What are Slug Guides? Why and how are you using them?
A.	 They are another set of guides similar to bleed guides. The slug area is 

often filled with info such as job information, printing info, editorial 
approval, etc. I am using the slug guides just as an extra set of guides, 
auto-fitting them to an area that includes the fold marks. This let’s you 
quickly choose whether or not you want them included in a print out or 
PDF. See the tip on the right for more info on how.

Q.	 Why can’t I edit the marks and guides made by the script?
A.	 The script’s default settings put them on a locked layer. You must unlock 

the layer before you can edit the contents: Go into the Layers panel 
(Window menu > Layers). Then click the lock next to the marks & 
guides layer. If you don’t want the script to lock this layer, double-click 
the Preferences script and uncheck Lock Marks & Guides Layer.

Q.	 Can I change the default settings in the main window?
A.	 Yes. Launch the Make Book Jacket script and enter the options you 

want. At the bottom of the dialog check on Make These Settings the 
Default and click OK. A jacket will be created, but your default settings 
have also been saved. If you don’t want the book jacket, just close the 
document without saving changes.

Tip—Viewing:
At the bottom of InDesign’s toolbox is a Normal button on the left and a 
Preview button on the right (in single column view it’s just one button). 
Click and hold the Preview button to select Bleed or Slug for other views. 

Once in Preview mode, open the Layers panel and show the appropriate 
Preview layer to view a section of your jacket in isolation. For instance you 
can look at just the spine, or just the front cover. This is how your audience 
will see the jacket on a book shelf! When done with one preview layer hide it 
and then show another Preview layer.

TIP—Speed it up with a keystroke:
You can assign a keyboard shortcut to the script. Then you can hit the 
keystroke to launch the script instead of using the Scripts panel. 
   �– Go into the Edit menu and choose Keyboard Shortcuts. 

– From the Product Area menu choose Scripts. 
– From the list choose the Make Book Jacket-[measurement] script. 
– Towards the bottom click in the empty field under New Shortcut. 
– Press the desired keys on the keyboard 
  (for example Option–J [MAC] or Alt–J [PC]). 
– Click Assign, then click OK.

TIP—Printing & making a PDF:
To print the jacket (or make a PDF) with bleed and fold marks: In the Print 
(or PDF) dialog’s Marks and Bleed section check on Include Slug Area. 
Please Note: This assumes you left Slug: Auto-Fit... checked in the main 
script dialog when you originally created the jacket.

FAQs & Tips
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Restoring original preferences & Default settings:
You can feel free to experiment with the scripts default settings and 
preferences, knowing that they can be reset to the “factory default” settings. 
These settings are stored in several text files located in:
MakeBookJacket4.0 > Manage Presets > z Support Files > Default Settings

There you will find a .txt file for each of the 3 types of measurements 
(inches, millimeters and picas). There may also be two other preference 
files. Delete any of these text files and the next time you run a script that 
needs them, you will be alerted that the default settings have been restored. 
NOTE: You can see these files in the Scripts panel (and delete them using 
the panel menu  at the top right).

explanation of preference files:

MakeBookJacketDefaults-Inches.txt (or Millimeters/Picas)

These three files store the default settings you see in the main dialog when 
you run the Make Book Jacket scripts. These include default sizes, bleed and 
mark settings, etc. These settings files get updated whenever a user checks on 
Update Default Settings in the Make Book Jacket main dialog.

Preferences.txt

When you run the Preferences script, the changes are saved into this file. 
This includes settings such as layer setup, InDesign Preferences, etc.

MakeUsingPresetDefaults.txt

This file isn’t too important, it’s only for remembering whether or not the 
Make Using Preset script dialog has the Show the Main Settings Dialog... 
checkbox checked or not. That is a “sticky” setting that is saved here.

For system Admins and advanced users:
The script is designed for use by individual users as well as multiple users 
in  companies. When the default settings have been deleted, the “factory 
settings” will be restored. Some users, especially companies with multiple users 
may want to customize those “factory defaults.” First you must understand 
a few things. The  “factory  defaults” are stored in: MakeBookJacket 4.0 > 
Manage Presets > z Support Files > Support Scripts-NOT FOR USERS > 
z Factory Default Settings

Here’s how the preference restoration works: First you delete a default/
preference file in the Default Settings folder. Then when you run a script that 
needs that file, you are alerted that the default settings have been restored. 
This means the script has copied the appropriate file in the z Factory Default 
Settings folder back into the Default Settings folder, thus restoring the 
“factory defaults.”

If you set your desired default settings and preferences, those settings are saved 
into the Default Settings folder. To customize the “factory defaults” you can 
then copy the files from the Default Settings folder into the z Factory Default 
Settings folder. Later  if a user deletes the files in Default  Settings, your 
custom “factory defaults” will be restored.

Dealing with Preferences
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Version Release Notes

Version 4.0  released 4/30/2011 (3.0 was released to only a few enterprise customers)

•	 Jacket dimensions such as spine, flaps, etc. can be modified after the 
file has been created. You can now change the spine width of an existing 
jacket (and more)! This only works on new jacket files created with 
MBJ 3.0 or later. It does not work on files created with MBJ 2 or earlier, 
or files you manually created. 

•	 Presets can be saved and used later to create jackets based on commonly 
used sizes. Presets can later be used, edited, renamed and deleted.

•	 Users can easily customize the main dialog’s default settings.
•	 Optional Spine Safety Guides can be added.
•	 The main dialog is better arranged with a simpler layout. Some options 

have been moved to a new Preferences dialog. The Preferences dialog lets 
you change the default layer names, optionally add an extra layer (such as 
a Type layer), and set a few common InDesign preferences.

•	 Preview layers can be added. To use them, switch into InDesign’s Preview 
mode. Open the Layers panel (Window > Layers). Then show/hide the 
appropriate preview layer so you can see part of the jacket in isolation. 
For example, view only front cover (spine and flaps are hidden).

•	 Users can now choose between 4 types of dotted/dashed Crop marks.
•	 A new Margin Safety allows margin guides to be fit to the spine/flaps but 

still have a margin inset from the other sides (such as top and bottom).
•	 Version 4.0 works in InDesign CS3, CS4, CS5 and CS5.5.

Version 2.0  released 10/26/2007

•	 The Flap Fold Turnaround (previously called Flap Fold Safety Zone) 
can now increase the document size. Previous versions did not add the 
Flap Fold Safety Zone to the document size, they were just guides added 
around the flap fold. If Turnaround Affects Document Size is checked, 
the script will now add that amount to the document size.

•	 Marks and guides can be put on a separate layer. This prevents them from 
being changed accidently and keeps them above all the jacket’s artwork.

•	 Crop marks can now be added. They use the same weight, length and 
offset as the fold marks, but are a solid line. I did not include this in 
previous versions because InDesign can add crop marks to prints and 
PDFs. But based on user requests, I have added this feature. Uncheck 
Add Crop Marks if you prefer to use InDesign’s built in crop marks.

•	 The crop and fold marks Offset Past Bleed can now have a negative value.
•	 Some default settings were changed:

– �Marks and guides are put onto their own layer and locked.  
Unlock this layer to edit the guides created by the script.

– �Crop Marks are now added by default.
– �Ruler Guides are no longer locked by default. Since the guides are put 

onto a layer that is locked, ruler guides are unlocked. This allows the 
user to freely add and edit their own guides, without disturbing the 
main guides for flap, spine, etc.

– �Turnaround Affects Document Size is checked by default, so unlike 
the Flap Fold Safety Zone of previous versions, the script will now 
increase the document size. If this is not desired, simply uncheck 
Turnaround Affects Document Size.

•	 Version 2.0 works in InDesign CS2, CS3, CS4, CS5 and CS5.5.

Version 1.1  released 6/21/2006

•	 Changed some of the dialog’s default amounts to better initial settings.
•	 Added a section of code near the top of the script to allow people to 

more easily customize the dialog’s default amounts to their own liking.
•	 In addition to inches, there are now scripts for picas and millimeters 

(also accepts cm). Thanks Karsten Luecke for input on the metric version.
•	 Version 1.1 works in InDesign CS, CS2, CS3 and CS4.

Version 1.0  released 12/7/2005

•	 Initial Release. Version 1.0 works in InDesign CS, CS2, CS3 and CS4.
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Licensing & Legal

Copyright and Credit
Copyright © 2005–2011 Daniel Rodney – instructor, graphic designer 

http://www.danrodney.com 
Adobe Certified Expert 
Adobe Certified Instructor

Use of the Make Book Jacket script is subject to the following terms: 
The Make Book Jacket script is the sole property of Daniel Rodney. 
The Make Book Jacket script is NOT to be distributed freely. 
No part of the script can be used and/or redistributed as your own.  
In other words: “Please don’t steal my hard work!”  J

Purchasing
For more information or to purchase a license: 

please visit http://www.danrodney.com 
or email dan@danrodney.com

Single-User License
Allows an individual to install and use this script on as many machines as he/she works 
on. It is not to be used by multiple persons. Only the person who purchased the license 
has the right to use this script. Multiple installed copies cannot be used concurrently. 
Since there is only one licensee, he/she can only be using one copy at a time. This license 
is nontransferable. 

Multi-User License
Allows a company, organization, household, etc. to install and use this script on multiple 
machines. The number of copies that can be installed and used concurrently depends on 
the number of licenses purchased. This license is nontransferable.
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